[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Cisco switch LACP + 802.1q
- Subject: Cisco switch LACP + 802.1q
- From: rcarpen at network1.net (Randy Carpenter)
- Date: Thu, 29 Sep 2011 13:33:48 -0400 (EDT)
- In-reply-to: <[email protected]>
I am tearing my hair out with an issue, and I hope someone can point something out to me that I am missing.
I am setting up 2-port LACP sets on a Cisco 2960G-24TS-L, which then need to be 802.1q trunk ports.
I have set it up as follows:
interface Port-channel1
switchport mode trunk
!
interface Port-channel2
switchport mode trunk
!
interface Port-channel3
switchport mode trunk
!
interface Port-channel4
switchport mode trunk
!
interface GigabitEthernet0/1
channel-protocol lacp
channel-group 1 mode active
!
interface GigabitEthernet0/2
channel-protocol lacp
channel-group 1 mode active
!
interface GigabitEthernet0/3
channel-protocol lacp
channel-group 2 mode active
!
interface GigabitEthernet0/4
channel-protocol lacp
channel-group 2 mode active
!
interface GigabitEthernet0/5
channel-protocol lacp
channel-group 3 mode active
!
interface GigabitEthernet0/6
channel-protocol lacp
channel-group 3 mode active
!
interface GigabitEthernet0/7
switchport mode trunk
channel-protocol lacp
channel-group 4 mode active
!
interface GigabitEthernet0/8
switchport mode trunk
channel-protocol lacp
channel-group 4 mode active
The problem is that after some period of time (sometimes minutes, sometimes hours), port-channel1 loses the "switchport mode trunk"
It just disappears from the config. If I try to put it back, it adds "switchport mode trunk" to the member ports (Gi0/1, Gi0/2) as well, which does not work. I have to tear it all out and start again. It will then work for a while again.
port-channel2 and port-channel3 are not in use yet, but port-channel4 is, and works just fine.
It is running IOS 15.0(1)SE. It was running 12.2 before, and it was doing the same thing, so I upgraded it to the latest available.
What could be the issue?
thanks,
-Randy